Tuner problems low frequencies high sample rate

Found a bug ? Report here

Tuner problems low frequencies high sample rate

Postby brad » Sun Feb 28, 2016 1:37 am

Im having some troubles using the tuner to read low frequencies such as open E string on a standard bass tune (41.2 Hz). The problem only occurs at higher sampling rates than 48000 Hz (Works fine at 44100 or 48000).

At 88200, 96000 & 192000 Hz sample rates the tuner will dance all over the place at lower frequencies (less than 49Hz) but becomes very stable reading a G or over (49HZ). (when playing up it seems to be stuck between reading the actual frequency and double the actual and then averaging somewhere in between)

Jack settings

- when at 44100 Hz im sampling 256 samples per block in 5.6ms blocks - no problems
- when at 48000 Hz im sampling 256 samples per block in 5.2ms blocks - no problems
- when at 96000Hz im sampling 512 samples per block in 5.2ms blocks - problem exists
- when at 192000 Hz im sampling 1024 samples per block in 5.2ms blocks - problem exists

Im not sure where the problem may be, but I happy to spend some time doing some testing or experimenting.

Thanks
User avatar
brad
 
Posts: 4
Joined: Sun Feb 28, 2016 1:17 am

Re: Tuner problems low frequencies high sample rate

Postby brummer10 » Sun Feb 28, 2016 5:36 am

Welcome Brad

Thanks for this detailed report!
Great finding. Well, now I know what happens (fft frame size to small on high sample rates) and could solve this issue by just use a fixed samplerate (41000Hz) in the pitchtracker.
Please try a new git checkout and report back if the tuner stabilized now at higher sample rates and low notes.

regards
hermann
User avatar
brummer10
Site Admin
 
Posts: 761
Joined: Thu Mar 26, 2009 6:57 pm

Re: Tuner problems low frequencies high sample rate

Postby brad » Mon Feb 29, 2016 12:29 am

Hi Hermann

I've checked out the latest git and the problem is solved, I was able to tune down past 20Hz as a test at 96000 Hz.

I was also very impressed with the new skins and look and feel, keep up the good work guys!

I've also had some stability problems (more startup issues) when trying to run Guitarix in 192000 mode (both with Ubuntu 2:0.34.0+git20151119.3v5 and latest git). Ill try to find some more information to go on here and post another thread but it was preventing me testing the tuner problem at 192000 Hz today. A quick strace showed it was core dumping with a SIGABRT after connecting to jack.

Many Thanks for your time and effort,
Brad.
User avatar
brad
 
Posts: 4
Joined: Sun Feb 28, 2016 1:17 am

Re: Tuner problems low frequencies high sample rate

Postby brummer10 » Mon Feb 29, 2016 2:43 am

brad wrote:I've checked out the latest git and the problem is solved, I was able to tune down past 20Hz as a test at 96000 Hz.


Good to hear.
brad wrote:I was also very impressed with the new skins and look and feel, keep up the good work guys!


Thanks, this is mainly the work of Markus aka. boomshop.
A real great designer, beside his programming skills, isn't he!! :metalbanana:
brad wrote:I've also had some stability problems (more startup issues) when trying to run Guitarix in 192000 mode (both with Ubuntu 2:0.34.0+git20151119.3v5 and latest git). Ill try to find some more information to go on here and post another thread but it was preventing me testing the tuner problem at 192000 Hz today. A quick strace showed it was core dumping with a SIGABRT after connecting to jack.


I've a idea what it could cause, unfortunately my sound-card didn't support 192kHz, so I cant test it, but I've pushed a possible fix for this to git. Before you start a debug session, you may try if my fix work.

regards
hermann
User avatar
brummer10
Site Admin
 
Posts: 761
Joined: Thu Mar 26, 2009 6:57 pm

Re: Tuner problems low frequencies high sample rate

Postby brad » Fri Mar 04, 2016 6:16 am

brad wrote:I've a idea what it could cause, unfortunately my sound-card didn't support 192kHz, so I cant test it, but I've pushed a possible fix for this to git. Before you start a debug session, you may try if my fix work.


Hi Hermann, unfortunately the problem still exists, ill do some dubug and report back with my findings.

thanks
brad
User avatar
brad
 
Posts: 4
Joined: Sun Feb 28, 2016 1:17 am

Re: Tuner problems low frequencies high sample rate

Postby brad » Sat Mar 05, 2016 4:06 am

Hi Hermann

Turns out the ladspa plugin ZynChorus was causing the problem, disabled it and now guitarix starts and runs in 192000 Hz mode. Tuner is also working perfect in this mode.

Thanks,
Brad.
User avatar
brad
 
Posts: 4
Joined: Sun Feb 28, 2016 1:17 am

Re: Tuner problems low frequencies high sample rate

Postby brummer10 » Sat Mar 05, 2016 4:28 am

Hi Brad

I'm glade to hear that,
thanks for report back your results.

regards
hermann
User avatar
brummer10
Site Admin
 
Posts: 761
Joined: Thu Mar 26, 2009 6:57 pm

Re: Tuner problems low frequencies high sample rate

Postby gimmeapill » Wed May 11, 2016 9:17 pm

I just made a test with my 5 string bass at 96k and am happy to report that even the low B is now working perfectly. It's actually the first time I see a tuner so precise for bass.
Nice job!
User avatar
gimmeapill
 
Posts: 84
Joined: Mon Jan 18, 2016 11:38 am
Location: Czech Republic


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron